logo

The Mad Modders

Välkommen till diskussionsforumet
Aktuellt datum och tid: sön 7 mar 2021, 01:33

Alla tidsangivelser är UTC + 1 timme [ Sommartid ]




Ny tråd Svara på tråd  [ 25 inlägg ]  Gå till sida Föregående  1, 2
Författare Meddelande
 Inläggsrubrik:
InläggPostat: tor 4 jan 2007, 02:54 
Offline
Domänadministratör

Blev medlem: lör 15 feb 2003, 14:39
Inlägg: 560
Jag tog bort prickarna i mitt schema för att det skulle bli tydligare.

Jag hade det där problemet från början när jag testade. Jag misstänkte glapp nånstans så jag plockade ner allt, flyttade IC-kretsen och bygdge upp det igen, och då funkade det. :p

Men det bör ju inte vara något glapp på ett kretskort.

Jag ser inga filer förutom de gamla 1 2 3 4 och de där 3D-bilderna.


Upp
 Profil  
 
 Inläggsrubrik:
InläggPostat: tor 4 jan 2007, 12:44 
Offline

Blev medlem: lör 17 apr 2004, 22:45
Inlägg: 28
Ort: Lödde i skåneland
hm,nä det bör ju inte vara glapp,förstår bara inte hur vippan kan uppföra sig så,den bör ju bara kunna switcha en gång per puls? inte en gång på framkant,å sen på bakkanten igen,som den verkar göra nu.. :/

konstigt att du inte ser filerna,prova shift-F5, för att uppdatera det färskt. Skriver direktlänkar här iaf:

http://web.telia.com/~u46712434/untitled.brd
http://web.telia.com/~u46712434/untitled.sch

Ska prova söka vidare sålänge. Tack för hjälpen


EDIT: Den verkar reagera på en klockpuls som även är väldigt låg,bara nån halv volt. Så jag funderar på om den är ostabil pga krypströmmar,lr nån form av "dubbelslag" (ja syftar på sånt som uppkommer vid mekaniska brytare),om de nu kan vara så att klockpulsen inte är så ren,utan den flaxar lite?

Nu bara e ja ute å svävar i områden som ja egentligen inte behärskar,men kan man inte sätta till en schmitttrigger för att säkerställa att pulsen verkligen blir antingen 0V lr 12v till klockingången?
MVh henrik


Upp
 Profil  
 
 Inläggsrubrik:
InläggPostat: tor 4 jan 2007, 21:03 
Offline

Blev medlem: lör 17 apr 2004, 22:45
Inlägg: 28
Ort: Lödde i skåneland
Hitta en 4093,nand me schmitt här hemma och fick de att funka med den,alltså så e de lite problem med klockpulsen uppenbarligen. men iom det var nand så fick ja koppla två eftervarann,så den inverterar sig sj igen.

Jag försöker leta på elfa,men borde de inte finnas en mindre krets med bara en Schmitt-trigger,eller dom ligger alltid inbakade med tex nand-grindar?
Hade ju räckt med en 4-bens ICkrets lr liknande.

Måste göra om schemat verkar det som iaf,eller du har nån annan lösning?

Mvh Henrik

Edit:tror klockingången reagerar på spänningsförändringar,och inte på om det är en logiskt etta lr nolla på flipfloppen.

Men ja fundera på en sak,alla transistorer å grejer du har,borde dom inte se till att klockpulsen antingen blir 0 eller 12V,o inte kunna ligga å flaxa lite. Kanske nått motstånd lr så som e lite snålt tilltaget? Kan somsagt inte den biten,försöker mindstorma till dig :P
Mv henrik


Upp
 Profil  
 
 Inläggsrubrik:
InläggPostat: tor 4 jan 2007, 22:44 
Offline
Domänadministratör

Blev medlem: lör 15 feb 2003, 14:39
Inlägg: 560
Nej 4013 reagerar ENDAST om klockingången går från låg till hög. Inte tvärtom.
Jag kontrollmätte många gånger, och nivån på pinne C1 är långt innanför gränsnivåerna, så det ska inte vara några problem.

Exakt vad har du för transistorer? BC547A B eller C? Eller några helt andra?


Upp
 Profil  
 
 Inläggsrubrik:
InläggPostat: fre 5 jan 2007, 01:18 
Offline

Blev medlem: lör 17 apr 2004, 22:45
Inlägg: 28
Ort: Lödde i skåneland
jag har transistorerna BC547C

Jo nivån på C1 är ursprungligen inga problem för mig iheller, dock vet ja inte vad problem är :s ,den ligger på ca 10v
Dock så går den inte ända ner till 0v vid logisk nolla,utan ligger runt 0,5.Men det bör väll vara inom gränserna. Fundera på om de är så att det är min ultraljudskrets som kanske sänder ut lite på K?så att det kommer,om än en liten,höjning i spänningen på slutet av pulsen? Men det bör iofs trollats bort genom din krets..


Det fungerade somsagt att koppla det genom en schmitt,om de hjälper dig?


Upp
 Profil  
 
 Inläggsrubrik:
InläggPostat: fre 5 jan 2007, 04:33 
Offline
Domänadministratör

Blev medlem: lör 15 feb 2003, 14:39
Inlägg: 560
Nja... Kanske är så att din 4013 är lite mer kräsen än min.
Du har väl en 4013, och inte en 74HC4013 eller så?
Iofs använde jag en MC14013, men enligt databladen ska det inte vara någon skillnad alls mellan den och en 73-471-15 på elfa.


Upp
 Profil  
 
 Inläggsrubrik:
InläggPostat: fre 5 jan 2007, 13:41 
Offline

Blev medlem: lör 17 apr 2004, 22:45
Inlägg: 28
Ort: Lödde i skåneland
mjo jag har en 73-471-15 ,en sk CD4013BE.

Det kanske e så att den är känsligare.
skulle vart intressant kanske att koppla in klockpulsen till en oscilloskop för att se hur den uppför sig? lr på nått sätt få ut spänningsvariationen grafiskt. Så man kan se om den verkligen går rakt ner,lr om den tar ett litet skutt i slutet,å därav omslagningen?

Hade ju varit enklare om man vetat exakt vad problemet är..


Upp
 Profil  
 
 Inläggsrubrik:
InläggPostat: fre 5 jan 2007, 17:12 
Offline
Domänadministratör

Blev medlem: lör 15 feb 2003, 14:39
Inlägg: 560
Ja precis. Du får skaffa ett oscilloskop då :french:


Upp
 Profil  
 
 Inläggsrubrik:
InläggPostat: lör 6 jan 2007, 00:46 
Offline

Blev medlem: lör 17 apr 2004, 22:45
Inlägg: 28
Ort: Lödde i skåneland
japp,får se om jag kan snoka rätt på ett när skolan börjar. tillsvidare får ja mecka ihop ett schema med nån schmitt inkluderat.. :P

Men en fråga då, Finns det någon liten IC-krets me endast en Schmitt-trigger i? eller de finns bara i form av "nand me schmitt","hex me schmitt" osv?
Hittar inget på elfa. Behöver ju egentligen bara den funktionen,å endast en IC-krets med en st sådan i,för att hålla det så litet som möjligt.
Jag kan inte hitta det på elfa,något du känner till?

Mvh Henrik,lägger uppnya scheman och ev. oscilloskåp-bilder här sen.


Upp
 Profil  
 
 Inläggsrubrik:
InläggPostat: lör 6 jan 2007, 01:00 
Offline
Domänadministratör

Blev medlem: lör 15 feb 2003, 14:39
Inlägg: 560
Schmitt-trigger är inte en sak i sig, utan beskriver ingångsegenskaperna för en logisk grind. Trig betyder utlösa.

En Schmitt-triggad grind har en "död-zon" mitt mellan låg och hög, där den inte reagerar på något.
Den går inte hög förrän insignalen går ovanför dödzonen, och den går inte låg igen förrän insignalen kommit nedanför dödzonen. Det är en hysteres.
Det är som ett slags störningsfilter kan man säga.

Det går att se på följande bild jag hittade:
Bild
A är insignal, och B utsignalen.
Vill du ha endast filteregenskapen så ska du använda en hex-buffer. Men de kommer också i minst 14-pinnars-kapsel, och innehåller 6st icke-inverterande grindar.


Upp
 Profil  
 
Visa inlägg nyare än:  Sortera efter  
Ny tråd Svara på tråd  [ 25 inlägg ]  Gå till sida Föregående  1, 2

Alla tidsangivelser är UTC + 1 timme [ Sommartid ]


Vilka är online

Användare som besöker denna kategori: Google [Bot] och 1 gäst


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Swedish translation by Peetra & phpBB Sweden © 2006-2010